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Initial Setup 

Setting up Integration with QuickBooks 

Installing the Method Integration Engine 

1. Choose a computer that is rarely turned off, and is usually logged into 

QuickBooks with Administrator permissions.  

2. Open QuickBooks to the company file you want to sync your Method account to.  

 

Note: Make sure you select the correct QuickBooks company file.  Once you link a 

QuickBooks company file to a Method account, you cannot easily link a different 

company file without having to create a brand new account. 

3. Sign into your Method account by going to http://www.methodintegration.com 

and clicking the Sign In link. 

4. Click on the QuickBooks tab. 

5. Under the Connect QuickBooks to your account section, step 3, click the Install 

now (click here) link. 

6. Download and install the Method Integration Engine by following the on-screen 

steps.  Be sure to install both QBFC and the Method Integration Listener. 

7. Once the installation is complete, you should be viewing the Method Integration 

Engine window.   

 

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in 

your taskbar next to the clock in the lower right-hand corner of your screen, and 

click Display. 

8. Enter your Method Account, User Name and Password.  

9. Click Connect.  

10. When prompted by QuickBooks, choose the 'Yes Always...' option. 

11. Wait until the full synchronization process completes. 

12. Close and reopen QuickBooks on this computer. This is an important step.  If you 

do not perform this step, the real time synchronization will not occur. 

13. Repeat steps 2 through 12 for all other computers that use QuickBooks.  This 

step will set the other computers to be “OnDemand From Desktop” mode so that 

changes made in QuickBooks sync automatically to the web. 

How do I know the installation worked? 

Verifying real-time syncing from QuickBooks to Method 

This test verifies that both the Method Integration Engine and the Method 

Integration Listener are installed and functioning correctly.  

http://www.methodintegration.com/
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1. In QuickBooks, add a customer named “AAAAAAAA”. 

2. Wait for 10 seconds. Note that in most situations the change is actually 

instantaneous. 

3. In Method, go to Customer Center > Customer List.   

4. You should see “AAAAAAAA” as a customer in the Existing Customers section. If 

you do not see the “AAAAAAAA” customer, click Refresh. 

If this process does not work, see the Troubleshooting chapter at the end of this 

guide for the Method Integration Listener and Method Integration Engine. 

Verifying real-time syncing from Method to QuickBooks 

Having performed the previous test above, this test verifies that the Method 

PUSH technology is working correctly. 

1. In the Existing Customers section of the Customer List screen, click Select next to 

the “AAAAAAAA” customer. 

2. Click Delete. 

3. Wait for 10 seconds.  Note that in most situations the change is actually 

instantaneous. 

4. In QuickBooks, go to your customer list and verify that the customer 

“AAAAAAAA” was deleted from QuickBooks. 

If this process does not work, see the Troubleshooting chapter at the end of this 

guide for Method PUSH. 

Setting up users 
A user is any employee or subcontractor you assign tasks to.  Typically, setting 

someone up as a user will grant them access to Method so that they can sign in.   

Allowing additional users to be added to your account 

1. Click the Customize tab.  If you don‟t see the Customize tab, change the Tab 

Group / Role in the top right to „Admin‟. 

2. Click the My Account tab link. 

3. Under the My Apps section, click “(change)” next to Method Starter / CRM / 

Full Blown edition (active). 

4. Change the number of users to be the total number of additional users that 

will need to sign into Method, and click change users.  

Creating new Users 

1. Click the Customize tab.  If you don‟t see the Customize tab, change the Tab 

Group / Role in the top right to „Admin‟. 

2. Click the Users tab link. 

3. Enter a new User Name. 
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4. Click Continue. 

5. Follow the steps on the screen.  Pay special attention to step 8 and step 9.  

Here you can both allow the user to only have access to certain Tab Groups / 

Roles, and also set the default Tab Group / Role that the user will see when 

they first sign in.  

6. Click either Add User & email invitation or Add User. 

7. The Edit Settings screen will appear.   

8. Set any additional preferences, and click Finish. 

Troubleshooting 

Troubleshooting – Installation of Method Integration Engine 

Use this section if you have errors during the installation process.  

Message: “Unable to install or run app” 

You may receive the following message: “Unable to install or run app.  The app 

requires that assembly Interop.QBFC8 Version 8.0.0.87 be installed in the Global 

Assembly Cache (GAC) first.” 

1. In Windows, click Start > Control Panel, or Start > Setting > Control Panel, 

depending on your version of Windows. 

2. Double-click on Add or Remove Programs. 

3. Look for QBFC, version 1.0 up to 8.0, and remove this program from your 

computer.  Note that this step may affect other QuickBooks integrated software.   

4. Perform a complete installation again by following the steps for “Installing the 

Method Integration Engine”.  

Recommendation: Ensure .Net framework is installed 

Please ensure that you have the latest updates for Windows .Net Framework. Not 

having this will prevent you from being able to install the QBFC and other files. 

1. In Windows, click Start > Programs > Windows Updates.  

2. Follow the instructions on your screen to install all recommended Windows 

Updates. 

3. Perform a complete installation again by following the steps for “Installing the 

Method Integration Engine”. 

Recommendation: Ensure you are installing with administrative permissions 

To find out if you have administrative rights: 

1. Right-click on the Start menu. 

2. If you see the “Open All Users” or “Explore all Users” options then you have 

administrative rights. 
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3. If you do not have administrative rights please contact you IT manager and ask 

them to log in and run through the installation steps. 

Troubleshooting – Method Integration Listener 

The Method Integration Listener is a tool that listens in real-time to changes that 

occur in QuickBooks, and notifies the Method Integration Engine to update the 

server.  

Step 1: Verifying the Method Integration Listener is installed 

1. In Windows, click Start > Control Panel, or Start > Setting > Control Panel, 

depending on your version of Windows. 

2. Double-click on Add or Remove Programs. 

3. Verify that Method Listener for use with QuickBooks is listed.   

4. If it is not listed, perform a complete installation again by following the steps 

above for “Installing the Method Integration Engine”.  

Step 2: Verifying the Method Integration Listener is integrated with 

QuickBooks 

1. In QuickBooks, click Edit > Preferences. 

2. Click on the Integrated Applications icon. 

 

3. Ensure that Method Integration Engine Listener is listed. 

4. If the Method Integration Engine Listener is listed, ensure that it has a checkbox 

under the Allow Access column. 

5. If it is not listed, open the Method Integration Engine, and click Synchronize > 

Changes-Only Synchronization.  Once the synchronization completes, close 

and reopen QuickBooks and try steps 1 to 3 again. 

 

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in your 

taskbar next to the clock in the lower right-hand corner of your screen, and click 

Display. 
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Step 3: Verifying the Method Integration Listener is hearing changes in 

QuickBooks 

1. In Windows, click Start > Run. 

2. Type “C:\Program Files\Method\ListenLog.txt” and click OK. 

3. Scroll to the bottom.  

4. Based on the date of the last entry, you should see evidence of recent changes 

being detected. 

 

5. If changes are not being picked up, check to see if the Method Integration Engine 

is running by right-clicking on the clock in the lower right-hand corner of your 

screen, choosing Task Manager, and ensuring that “MethodQBListen” is listed 

under the Applications tab. 

6. If MethodQBListen is running, but changes are not being written to the 

ListenLog.txt, there could be a permissions issue. 

a. Navigate to C:\Program Files. 

b. Right-click on the “Method” folder, and choose Properties. 

c. Click on the Security tab. 

d. Ensure Full Control is granted to all users on this folder. 

7. If MethodQBListen is not running, but Method Integration Listener is listed under 

Integrated Applications in QuickBooks, there could be a problem with a corrupt 

COM Add-In file for QuickBooks. 

a. Delete the file C:\Documents and Settings\All Users\Application 

Data\Intuit\QuickBooks\qbsubconfig.xml. 

Note:  If you are unable to locate this file, use the Find tool on your 

computer to search for the file called „qbsubconfig.xml‟.  

Note: Deleting this file will cause all QuickBooks COM add-ins to re-create 

their subscriptions.  This should happen automatically next time 

QuickBooks is started. 

b. Close and reopen QuickBooks. 

Step 4: Verifying the Method Integration Listener is sending changes to the 

Method Integration Engine 

1. Navigate to the Engine Log folder.   

If you are using Windows XP, the Engine Log folder is typically “C:\Documents 

and Settings\All Users\Application Data\MethodIntegration”.   

If you are using Vista or later, the Engine Log folder is typically 

“C:\ProgramData\MethodIntegration”. 
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Note: If you are using Vista or later and do not see this folder, you must edit 

your computer settings to show hidden folders: 

a. Click Start > Control Panel. 

b. Click Folder Options. 

c. Click the View tab. 

d. Click Show hidden files and folders.  If you want to see system files as 

well, unclick Hide protected operating system files (Recommended). 

e. Click OK. 

2. Delete the log file if it already exists.  This is typically your “QuickBooks Company 

File.qbw”. 

3. Ensure the Method Integration Engine is open and connected.  

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in your 

taskbar next to the clock in the lower right-hand corner of your screen, and click 

Display. 

4. Make a change in QuickBooks, such as creating a new customer. 

5. Refresh the Engine Log folder to see if the log file was recreated. 

6. If the log file was not recreated, there may be a permissions issue on this folder 

(see next step below). 

7. If the log file was recreated, open it and see if the change was picked up by the 

Method Integration Engine.  If the Method Integration Engine is open, and it is 

currently not synchronizing, and the log file is empty, everything is working as it 

should.  However, if it is currently not synchronizing and the log file is not empty, 

there may be a permissions issue on this folder. 

To ensure there are sufficient permissions on the Engine Log folder: 

a) Right-click on the folder and choose Properties. 

b) Click the Security tab. 

c) Add permissions such that all users have Full Control and click 

OK. 

If the steps above succeed, the Method Integration Listener is working 

correctly. 

Troubleshooting – Method Integration Engine 

The Method Integration Engine is the main synchronization tool that shuttles 

changes back and forth between QuickBooks and the web server.  

Step 1: Verifying the Method Integration Engine is installed 
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1. In Windows, click Start > Control Panel, or Start > Setting > Control Panel, 

depending on your version of Windows. 

2. Double-click on Add or Remove Programs. 

3. Verify that both Method Integration Engine for use with QuickBooks is listed, and 

QBFC 8.0 is listed. 

4. If either is not listed, perform a complete installation again by following the steps 

above for “Installing the Method Integration Engine”.  

Step 2: Verifying the Method Integration Engine is integrated with 

QuickBooks 

1. In QuickBooks, click Edit > Preferences. 

2. Click on the Integrated Applications icon. 

3. Ensure that Method Integration Engine for use with QuickBooks is listed. 

4. If the Method Integration Engine for use with QuickBooks is listed, ensure that it 

has a checkbox under the Allow Access column. 

Step 3: Verifying error free synchronization 

1. Ensure that you are logged into QuickBooks as an administrator if it is a first time 

synchronization. 

2. If you are using Vista, make sure UAC is turned on. 

a. Click Start > Control Panel. 

b. Type “UAC” into the search box. 

c. You should see an option “Turn User Account Control (UAS) On Or Off”. 

Click this link. 

d. Choose to turn UAC “On”. 

e. Click Save. 

f. Restart your computer. 

3. With QuickBooks open, open the Method Integration Engine. 

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in your 

taskbar next to the clock in the lower right-hand corner of your screen, and click 

Display. 

4. Click Synchronize > Changes-Only Synchronization. 

5. When the synchronization completes, check the Activity area and scroll down to 

see if there are any messages that start with “Error”. 
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6. If there are error messages, see if there are any recommendations written beside 

the error, and if so follow the recommendation. 

7. If you receive a message that reads “An internal error has occurred…”, it likely 

points to either an issue with QuickBooks, or corruption in your QuickBooks 

company file. 

a. To check for updates in QuickBooks, click Help > Update QuickBooks. If 

there are any updates to download you should download and install them, 

restart your computer, and try to synchronize again. 

b. To check for corruption in your QuickBooks company file, click File > 

Utilities > Rebuild Data. After the process completes, try to synchronize 

again. 

8. If error messages persist, check for QuickBooks SDK issues by running a QBSDK 

Test: 

a. Open QuickBooks to the correct company file. 

b. In QuickBooks, click F2. 

 

c. Highlight the text in the Location text box in the File Information section. 

d. Right-click and choose Copy. 

e. Download and run the following utility: 

http://www.alocet.net/utilities/qbmodifycustomer4.exe  

f. In qbmodifycustomer4, paste the path into the Please enter the QB file 

name in full path text box. 

http://www.alocet.net/utilities/qbmodifycustomer4.exe
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g. Click Next. 

h. Choose “Yes Always”. 

i. Select a customer from the Customer Full Name List. 

j. Click Modify. 

k. Click Modify Customer. 

9. If the QBSDK Test failed, you will likely have to reinstall QuickBooks. To properly 

reinstall QuickBooks: 

a. Make a backup of your QuickBooks company file. 

b. Uninstall QuickBooks from Start > Control Panel > Add / Remove 

Programs. 

c. Manually delete the “C:\Program Files\Common Files\Intuit\QuickBooks” 

folder. 

d. Reinstall QuickBooks. 

10. For further assistance, please contact technical support. 

Troubleshooting – Method PUSH 

Method PUSH is the technology that allows changes made in Method to sync in 

real-time back to QuickBooks.  In order for this to occur, the Method Integration 

Engine initiates a TCP/IP connection to the server.  If your IT manager has 

blocked outgoing TCP/IP connections or has blocked ports on your network, 

Method PUSH may not work.  

Step 1: Verifying the Method Integration Engine is installed 

1. With QuickBooks open, open the Method Integration Engine. 

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in your 

taskbar next to the clock in the lower right-hand corner of your screen, and click 

Display. 

2. Enter your Method Account, User Name and Password. 

3. Click Connect. 

4. Wait until the synchronization is complete. 
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5. Check the Method PUSH status. 

 

6. If the status shows “Connection Failure” instead of “Connected” or “Not 

Connected”, an issue with establishing an outgoing TCP/IP connection has 

occurred. 

a. Hover your mouse over the “Connection Failure” label to see if additional 

information about the message shows. 

b. Check with your IT manager to ensure that you have a high-speed 

internet connection. 

c. Check with your IT manager to ensure that your anti-virus and firewall 

settings permit an outgoing TCP/IP connection. 

7. If your IT manager would like to only allow Method to use a specific port range, 

please follow the steps below: 

a. Navigate to the Engine Log folder.   

If you are using Windows XP, the Engine Log folder is typically 

“C:\Documents and Settings\All Users\Application 

Data\MethodIntegration”.   

If you are using Vista or later, the Engine Log folder is typically 

“C:\ProgramData\MethodIntegration”. 

Note: If you are using Vista or later and do not see this folder, you must 

edit your computer settings to show hidden folders: 

b. Create an empty text file called “MethodPush.config”. 

c. Edit the MethodPush.config file. 

d. Put the following into the contents of the file, where 3000 is an example 

for the lowest port number in your IT manager‟s desired range, and 3100 

is an example of the highest port number in your IT manager‟s acceptable 

range. 
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<LocalPortMin>3000</LocalPortMin> 
<LocalPortMax>3100</LocalPortMax> 

e. Save and close the file. 

f. In the Method Integration Engine click Disconnect, and then Connect. 

Uninstalling the Method Integration Engine and Listener 

NOTE: If you have attempted to remove Method from your computer already, 

you will need to reinstall Method in order to properly follow the steps below.  To 

reinstall Method, follow the steps under the QuickBooks tab.  Once that is done, 

proceed with the steps below.  

1. Open QuickBooks.  

2. Open the Method Integration Engine. 

Note: If the Method Integration Engine is not open, click Start > Programs > 

Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in your 

taskbar next to the clock in the lower right-hand corner of your screen, and click 

Display. 

3. In the Method Integration Engine, click Disconnect.  

4. Click Synchronize > Real time QuickBooks Subscription > Remove 

Subscription.  

5. Click File > Shut Down.  

6. In QuickBooks, click Edit > Preferences. 

7. Click Integrated Applications. 

8. Click the Company Preferences tab.  

9. Click Method Integration Engine Listener.  

10. Click Remove.  

11. Click Yes. 

12. Click Method QuickBooks Desktop Integration Engine for use with QuickBooks.  

13. Click Remove.  

14. Click Yes.  

15. Click OK.  

16. Click File > Exit. 

17. Once QuickBooks is closed, try to reopen it.  If you receive the message to 

enable Method with QuickBooks again, click Cancel and continue with the steps 

below.  If you do not receive a prompt from QuickBooks asking for Method to 

connect, move to step 18.   

a. Ensure QuickBooks is closed.  
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b. Open My Computer and navigate to: C:\Documents and Settings\All 

Users\Application Data\Intuit\QuickBooks 

Note:  If you are unable to locate this file, use the Find tool on your 

computer to search for the file called „qbsubconfig.xml‟.  

c. Delete the file called qbsubconfig.xml.  

d. Reopen QuickBooks. 

18. In Windows, click Start > Control Panel > Add or Remove Programs.   

19. Remove the Method Integration Engine. 

20. Remove the Method Integration Listener. 

QuickBooks Integration FAQ 

Q1: Why can‟t I do a Changes-Only synchronization on computers other 

than the „main‟ computer? 

A1: Limiting Changes-Only and Full Synchronization to a single computer eliminates 

the possibility to two computers synchronizing the same data between QuickBooks 

and the server at the same time.  This reduces your network traffic, the number of 

requests made to QuickBooks, bandwidth between your network and the server, as 

well as prevents database records from being edited by multiple synchronizations at 

the same time. 

Q2: How do I change the computer I use as the „main‟ synching computer? 

A2:  

a) Confirm you have the correct company file open in QuickBooks.  

b) In Method click the QuickBooks tab. 

c) Under the Edit Synchronization Preferences section, click Reset beside 

Computer to Sync With. 

d) Click Save Changes. 

e) On the computer you want as the new „main‟ synching computer, install 

the Method Integration Engine and run a full synchronization. 

Q3: How do I reset my account and use a different QuickBooks file? 

A4: When you sync your QuickBooks company file to your Method account the 

company file and the account are bound together. You cannot reuse an account on a 

different QuickBooks company file without causing data conflicts and inconsistencies.  

If you need to sync a second company file, you‟ll need to open a second account.  

Q4: I have renamed my QuickBooks company file, but it is otherwise the 

same.  How do I allow my Method account to sync with this? 

A4:  

a) Confirm you have the correct QuickBooks company file open. 

b) In Method click the QuickBooks tab. 
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c) Under the Edit Synchronization Preferences section, click Reset next to 

QuickBooks file. 

d) Open the Method Integration Engine. 

Note: If the Method Integration Engine is not open, click Start > Programs 

> Method > Method Integration Engine for Use with QuickBooks.   

If the Method Integration Engine is not visible, right-click on the  icon in 

your taskbar next to the clock in the lower right-hand corner of your screen, 

and click Display. 

e) In the Method Integration Engine click Connect. 

Q5: What version of QuickBooks do I need in order to use Method? 

A5:  

US versions of QuickBooks Pro/Premier/Enterprise 2004 or higher 

Canadian versions of QuickBooks Pro/Premier/Enterprise 2008 or higher 

UK versions of QuickBooks Pro/Premier/Enterprise 2008 or higher 

Australia versions of QuickBooks Pro/Premier/Enterprise 2008 or higher 

Note: Only Windows versions are supported.  There is no integration for 

QuickBooks for Macintosh. 

QuickBooks Free, QuickBooks Simple Start and QuickBooks Online are not 

supported. 

Q6: Does QuickBooks need to be open in order to use Method? 

A6: You can still use Method to access and modify information even if QuickBooks is 

closed. Any changes will be synchronized with QuickBooks next time it is opened on 

the main synching computer. If you want to take advantage of Method‟s real-time 

syncing, QuickBooks must be open, and be open to the correct company file. 

Q7: Does Method work on a Mac? 

A7: The Method Integration Engine must be installed on a Windows computer. 

Dispatchers, however, can log in to their Method account via FireFox for Macintosh. 

Q8: What happens to my data if I cancel my account? 

A8: Once we have confirmed your cancellation your Method data will be permanently 

deleted within 30 days. 

 

 


