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Method Xora Connector Documentation 

Prerequisites 

1. As the Method-Xora connector allows users to export service times directly into 

QuickBooks, it is important to have active employees setup in the QuickBooks 

Employee Center.  Payroll Items will need to be setup as well.  Click Edit > 

Preferences > Payroll, then select the Company Preferences tab and make sure 

Payroll is turned on.  To create a Payroll Item, edit an employee in QuickBooks and 

select the Payroll tab or dropdown. Then click in the Item Name column under 

Earnings and the dropdown < Add New > will appear. 

2. Internet Explorer Users: Ensure that the security permissions in IE are adjusted for 

the Connector to execute.  Click Tools > Internet Options.  Select the Security tab 

and click the Custom Level button.  Scroll down to the Downloads subheading, and 

make sure that Automatic prompting for file downloads is set to Enable. 

3. Firefox Users: Ensure that Mozilla Firefox is installed.  This can be downloaded from: 

http://www.mozilla.com/firefox. Click the Free Download link and follow the setup 

instructions.  Next, download and install the Firefox add-on FFClickOnce 0.8.  This 

can be located here: https://addons.mozilla.org/en-US/firefox/addon/1608.   Click 

the Download Now link, and follow the instructions to save and run the add-on. 

4. You will also need to download the .NET 3.5 Framework.  This is a manual update 

and can be located here: 

http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-

B531-508D977D32A6&displaylang=en.  Make sure you are up to date with all 

automatic updates first, including optional updates such as the .NET framework 1.1 

and 2.  See the Appendix if you are unsure of how to update your framework. 

 

Registering 

1. To register a new Method-Xora account, bring up the website here: 

https://www.methodintegration.com/web/SignUpApp.aspx?app=Xora Connector. 

2. Fill out the required fields and click Login. 

3. An e-mail will immediately be sent to the registered e-mail account.  Make sure to 

refresh the inbox, as well as check any Trash or Junk Mail folders to ensure it has 

arrived. 

4. You will now be able to login to the new Method Account here: 

https://www.methodintegration.com/method/Login.aspx.  

 

Initial Setup 

1. After logging into your Method Account.  It is important to setup a relationship with 

QuickBooks. 

2. Click on the QuickBooks tab at the top, and follow the instructions under the 

section Connect QuickBooks to your Method Account. 

3. Once Method has been synchronized with QuickBooks, you should see all of your 

QuickBooks Customers, Items and Employees in Method. 
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Method Xora Connector Preferences 

1. The Method Xora Connector Preferences are essential to importing times into Method 

and then into QuickBooks.  To setup these preferences, click on the Xora Connector 

> Xora Setup tab. 

2. Click on Launch Preferences under the Method Xora Connector Preferences 

section. 

3. First, you must fill out your Account Information for both Xora and Method.  Enter 

your Xora Account ID, Xora User ID and Xora Password. This is the same Admin login 

information you would use when logging into your Xora account here: 

https://apps.xora.com/xoraapps/jsp/AppLogin.jsp. 

4. Enter your Method Account number, Method UserID and Method Password.  This can 

be found in your Welcome To Method email that was sent upon registration. 

5. Next choose your Default Items.  A default Shift or Job item is used when no 

mapping data is found when pulling times from Xora into Method.  For example: You 

have mapped the customer Bob Crenshaw to Job Number 145, and to a QuickBooks 

Class „pro‟ using the Job/Customer Mapping screen.  However, you have not mapped 

customer John Smith.  When Method imports times from Xora, the default Shift or 

Job Class will be assigned to the service time for John Smith whereas the service 

time for Bob Crenshaw will use the Class „pro‟. 

6. If no matching Job number is found in the Job/Customer Mapping screen, a default 

Shift Time or default Job Time Class, Service and Payroll Item will be assigned.  If 

there are no items available in the dropdown list, they will need to be created in 

QuickBooks.  If you do not want a default item assigned, simply leave it blank. 

7. The Default Billable status will flag a job time as billable or not in QuickBooks.  I.e. 

The job time will be able to append an invoice with its amount. 

8. Overtime calculation preferences are set here, but done in the Step2 Send to 

QuickBooks screen.  Set the Max Hours per Day (Before Overtime) in order to 

determine how many hours in a day should be considered regular hours before going 

into overtime. 

9. Set the Max Hours per View (Before Overtime) in order to determine how many 

hours in your Send to QuickBooks screen view should be considered regular hours 

before going into overtime.  As you are not limited to choosing a specific view (i.e. 

week, month, user), make sure you always have the proper number entered here 

before attempting to Allocate Overtime by View. 

10. The Default Overtime Payroll Item is used when allocating Overtime in the Send to 

QuickBooks screen. 

11. Time Preferences are used to indicate which times are to be used from Xora and 

how. 

12. The Time Zone preference is used for sending jobs to Xora, through the 

Job/Customer Mapping screen.  Make sure the proper Time Zone is set before 

attempting to send jobs to Xora. 

13. Use Shift Times enabled by itself, will exclude job times found in Xora.  For example: 

If a user logs into Xora on their mobile phone and begins a Shift, performs and logs 

3 jobs, then ends the shift.  Only the Shift Start and Stop time will be brought over 

for a one time entry. 

14. Use Job Times enabled by itself, will exclude Shift Times found in Xora.  For 

example:  If a user logs into Xora on their mobile phone and begins a Shift, performs 

and logs 3 jobs, then ends the shift.  Only the Job Start and Stop times for the 3 jobs 

will be brought over for 3 time entries. 

15. Use Custom Job Times is available for Xora Gold/Premier/Wireless Workforce 

Manager users.  You will be able to bring in Custom Job Statuses and their 

timestamps from Xora into Method.  This by itself will also exclude Shift Times found 

https://apps.xora.com/xoraapps/jsp/AppLogin.jsp


in Xora.  For example:  If a user logs into Xora on their mobile phone and begins a 

Shift, performs and logs 3 jobs, then ends the shift.  Only the custom job statuses of 

the 3 jobs will be brought over for job time entries. 

16. Enabling or disabling both options, will result in bringing over both Shift and Job 

Times as separate time entries. An adjustment will appear next to the shift to 

compensate for the total job time spent.  For example:  If a user logs into Xora on 

their mobile phone and begins a Shift, performs and logs 2 jobs, then ends the shift.  

The Shift Start Time and Stop time will come for one time entry, and the Job Start 

and Stop Times for the 2 jobs will be brought over, creating another 2 entries. 

17. Note that you can only use Custom Job Times or Job Times.  Not both. 

18. Lunch and Travel Times settings are used to indicate if you would like to adjust your 

times (placed in the adjustment column of the Send to QuickBooks screen) 

19. Enabling Add Travel Time to Job Time will apply the travel to the Shift or Job Time. 

Disabling it will cause an adjustment to appear. 

20. Enabling Add Lunch Time to Shift Time will apply the lunch to the Shift or Job Time.  

Disabling it will cause an adjustment to appear. 

21. Travel Time as Separate Entry, will place travel time associated with a Shift or Job as 

a separate time entry. 

22. The Default Travel Service Item is the default Service Item applied for the previous 

option, when a new time entry of type travel is added. 

 

FlexField Mapping 

Xora allows the tracking of custom data entry through fields called FlexFields.  They can be 

applied to Shifts, Jobs or both in Xora.  Xora users who wish to track information regarding 

the start or stoppage of shifts/jobs track this information.  This information can be brought 

into Method to help flag certain Shift or Job times. 

 

1. To open FlexField Mapping, click on the Xora Connector > Xora Setup tab. 

2. Next click the Launch Mapping button, under the FlexField Mapping section. 

3. This screen will allow you to map up to 10 custom fields, as well as a Notes field. It 

is important to type in the exact name of the Shift FlexField or Job FlexField.   

4. When a matching FlexField is found during a Get Xora Time action, the resulting 

value of that FlexField is placed in the appropriate Method field.  This is useful for 

flagging times as needing attention.  The Mapped Notes field (to whichever FlexField 

of your choice) is the only field that will actually be sent to QuickBooks, the Custom 

fields will remain in Method. 

5. If you would like to map the Xora Comment field to Method, simply type in the word 

Comment in any Custom1-10 field, or the Notes field.  Please note that this name is 

reserved and should not be used as a FlexField name in Xora. 

6. If you are using Custom Job Statuses in Xora, you can map the Job Status Name to a 

Custom1-10 field or the Notes field.  Simply type in the name JobStatusName (no 

spaces).  Please note that this name is also reserved and should not be used as a 

FlexField name in Xora. 

 

FlexField Value Mapping 

FlexField Value mapping gives you the opportunity to assign different QuickBooks items to 

Service Times, such as ServiceItem, BillableStatus, PayrollItem and Class.  This is useful if 

you have codes setup for your Xora Users to enter into their FlexFields, depending on which 



work was performed.  For instance, if your Xora User performed a Grass Cut for a customer, 

they would enter the code GRASS into their FlexField for the current job they are 

performing.  When the Method Xora Connector brings in the completed job, it will look at 

the FlexField Value Mapping table, and assign a QuickBooks Service Item “Lawn Mowing” to 

the service time. 

 

1. To open the FlexField Value Mapping screen, click on the Xora Connector > Xora 

Setup tab. 

2. Next, click Launch Mapping button, under the FlexField Value Mapping section. 

3. To enter in a new mapping, enter a Name and Value and click Save.  The name 

should be identical to the FlexField being used in Xora. 

4. To edit an existing mapping, click Select, make your changes and click Save. 

5. To delete an existing mapping, click Select and then click Delete. 

6. To clear the screen for a new entry, click Clear. 

 

Xora Custom Job Statuses 

The Xora Custom Job Statuses window allows you to specify which Xora Job Statuses are 

used for Time Tracking.  This screen is used directly with Custom Job Statues and will 

require that you are a Xora Gold/Premier/Wireless Workforce Manager user, and that you 

have Use Custom Job Times enabled under Xora Connector > Xora Setup > Launch 

Preferences. 

 

1. To open the Xora Custom Job Statues window, click on Xora Connector > Xora 

Setup > Launch Statuses. 

2. To create a new JobStatus, click Clear/New.  Enter in the Job Status Name as it 

appears in Xora.  This can be found at https://apps.xora.com under Setup > View 

Profiles.  Then, select your profile and expand the Job Tracking section. 

3. Check whether the Job Status should be trackable and then click Save. 

4. To edit an existing Job Status, click Select beside it, then make the necessary 

changes below and clicking Save. 

5. To delete an existing Job Status, click Select beside it, and then click Delete. 

6. If you would like to setup default QuickBooks items for one or more Job Statuses, 

simply choose a Service Item, Class, Payroll Item and/or billable status before saving 

an entry.  Leaving these fields blank will cause no mapping of QuickBooks items to 

the times in this instance. 

 

 

Send/Map Xora Jobs 

The Send/Map Xora Jobs window allows you to match QuickBooks Customers with Xora 

Jobs.  A user can either enter the Job in Xora, then create a matching entry in the 

Send/Map Xora Jobs screen *or* they can create the job in the Send/Map Xora Jobs screen 

and later send it to Xora. 

 

1. When a new time entry is fetched from Xora, Method will fill in the Class, Payroll, 

Service, Customer and BillableStatus for the time entry with a matching Job Number. 

2. To open the Send/Map Xora Jobs screen, click on Xora Connector > Send/Map 

Xora Jobs. 

https://apps.xora.com/


3. The Existing Mapped List section is used to display a list of your existing 

Customer/Job mappings in a filterable grid.  You can select an existing one by 

clicking Select. 

4. The Edit or Create Xora Job Mapping section is used for editing the details of a new 

or existing Customer/Job Mapping.   

5. To add in a new Customer-Job relationship, click Clear/New and fill out the text 

boxes and click Save. 

6. When new times are fetched in from Xora, the Job number is compared to this list. If 

a matching Xora number is found then the Class, Payroll, Service, Customer and 

BillableStatus items will be used instead of your default preferences. 

7. See Editing and Sending Times to QuickBooks for a quick mapping option. 

 

Sending Jobs to Xora 

Once you have successfully mapped Job/Customers in Method, you have the option to send 

these jobs to Xora.  This will allow the mobile phone users to download the jobs and 

complete them.  Coming full circle, you will bring in the completed Job/Shift Times from 

Xora, and Method will map the specific Items (i.e. Class, Service, etc) for the times that 

were associated with the Job/Customer Mapping.  Before attempting to send jobs, make 

sure to setup Xora Users.  This can be done by enabling Xora User and Xora Employee 

Number in the Employee > Additional Info tab, or the Vendors/Subcontractors > 

Additional Info tab. 

 

1. To open the Send to Xora screen, click Xora Connector > Send/Map Xora Jobs. 

2. Click Select beside a Job/Customer Mapping and click the Send to Xora button.  If 

there are no mappings you will need to create one. 

3. The Send to Xora screen will now appear. 

4. Select at least one Xora User from the dropdown. 

5. If there are no Xora Users to select from the dropdown list, you will need to set some 

of your Employees or Subcontractors as Xora Users.  To do so, select the Employees 

tab, select an existing employee and click Additional Info.  Alternatively, this can be 

done with a subcontractor by clicking Vendors / Subcontractors > Additional Info.  

The employee or subcontractor will need to be enabled as a Xora User, and a 

matching Xora Employee Number will need to be entered.  This should be the same 

Employee Number as found in Xora, under Setup > Users here: 

https://apps.xora.com/xoraapps/jsp/AppLogin.jsp.  

6. Finally, set a date range using the Available from, Available to and Scheduled Start 

Time date pickers then click Send to Xora.  The results of sending the job will be 

returned by Xora and displayed in the Xora Schedule Status text area. 

7. To send the job to Xora as unassigned, click the Send to Xora as Unassigned 

button. 

8. If you would like to send the location of the job, make sure to enter the longitude 

and latitude of the Customer in Method.  This can be found under Xora Connector 

> Customers.  You will need to select a customer and enter their longitude and 

latitude under the Address Info tab and click Save.  This information is not saved in 

QuickBooks. 

 

 

Get Xora Time 

https://apps.xora.com/xoraapps/jsp/AppLogin.jsp


With everything mapped and your preferences set, it is time to begin tracking times in Xora 

and then importing it into Method.  The process would be as follows:  You either create and 

dispatch several jobs in Method and send to Xora or do so from within Xora.  The Xora user 

then downloads the jobs to their phone and begins tracking all associated times for their 

Shift and/or Jobs.  Once they are finished, you can import those times to Method. 

 

1. In order to retrieve new time entries from Xora, click the Xora Connector > 

Connect with Xora tab. 

2. Next click the Step 1: Get Xora Time tab. 

3. Choose a Date range by choosing a date for Jobs/Shifts that start on or after, and 

for Jobs/Shifts that end on or before. 

4. Select one or more Xora Users that you would like to retrieve times for. 

5. If there are no Xora Users to select from the dropdown list, you will need to set 

some of your Employees or Subcontractors as Xora Users.  To do so, Select the 

Employees tab, select an existing employee and click Additional Info.  

Alternatively, this can be done with a subcontractor by clicking Subcontractors > 

Additional Info.  The employee or subcontractor will need to be enabled as a Xora 

User, and a matching Xora Employee Number will need to be entered.  This 

should be the same Employee Number as found in Xora, under Setup > Users 

here: https://apps.xora.com/xoraapps/jsp/AppLogin.jsp. 

6. Click the Get Xora Time button. 

7. If prompted, click Run ClickOnce Application. 

8. The Method Xora Connector window will appear, and will display its progress at 

the bottom of the Window. 

9. The results of fetching times from Xora will be displayed in the scrollable textbox.  

If a time is retrieved, it will display “Retrieved new (Shift/Job/Travel) Time for 

user…”.  If no times were located it will display “No (Shift/Job) Times were 

located for the matched Xora Users”.  If all times found already exist in the Step 

2: Send to QuickBooks screen, it will display “All available times are already in 

Method.  No new times located.”. 

10. If you would like to see the data that was returned by Xora, you can click the 

Show Xora Data button. 

11. To view the time entries that were added, select the Send to QuickBooks tab.  

If no new entries appear, click the Refresh button. 

 

Note: Only completed Shifts and Jobs will be returned.  Additionally, Xora has throttling 

restrictions on some of its users which is why an error message from Xora might appear.  

Throttling is done to limit how often a call is made to the Xora server and how much data is 

returned.  For a list of throttling rules which may affect retrieving Xora Times, please see 

the appendix. 

 

 

 

Allocating Overtime 

Most QuickBooks users assign different payroll items to their employees or subcontractors, 

depending on the work that was performed.  The most commonly used is an Overtime Payroll Item, 

when a worker goes beyond the regular hours assigned to them.  The Connect with Xora screen 

will allow you to allocate Overtime for service times that have been brought into Method. 

 

https://apps.xora.com/xoraapps/jsp/AppLogin.jsp


1. Before attempting to allocate overtime, make sure you have a Default Overtime Payroll 

Item set in the Xora Setup > Preferences window.  You should also have the Max Hours 

per Day and Max Hours per View entered as well.   

2. In order to allocate overtime, click Xora Connector > Connect with Xora. 

3. Select the Step 2: Send to QuickBooks tab. 

4. A list of time entries will appear here, that have been brought in from Xora.  If you currently 

do not see any time entries, try changing the Date Range and/or Filter by View and click 

Refresh. 

5. Select the time entries that you would like Method to look for Overtime for by checking the 

boxes on the left.  It is important to select all time entries related to that Day or View and 

not a single time entry. 

6. Click Allocate Overtime per Day if you are tracking overtime on a daily basis.  Each user‟s 

total time per day will be compared to the Maximum Hours per Day found from your 

preferences.  If any day is found to go into overtime on a day, a new overtime service time 

will be added for the amount of minutes that went into overtime.  In addition, service times 

will be retroactively removed and/or altered in order to compensate for the new overtime 

time entry.  This is done so that each user‟s total time before this operation took place, 

matches their total time after allocating for overtime.  This process will work with any 

viewable service times on one day or on multiple days. 

7. Click Allocate Overtime per View if you are tracking overtime on any other basis.  This 

can include weekly, biweekly, monthly or on a user by user basis.  Each user‟s total time for 

the current view will be compared to the Maximum Hours per View found from your 

preferences.  If the total time for any user is found to go into overtime, a new overtime 

service time will be created.  This will make retroactive adjustments the same as the 

Allocate Overtime per Day operation. 

 

 

 

Editing and Sending Xora Times to QuickBooks: 

 

Once job and shift times have been fetched from Xora, it is now time to send them to 

QuickBooks.  This is an intermediary step that gives you the ability to first alter / massage 

the times before sending to QuickBooks, if you choose to do so.  Note also, that since the 

Xora Connector is built on the "Method Integration" platform, all screens are fully 

customizable, giving you the ability to add your own functionality, which can be especially 

useful in the massaging process. 

 

1. In order to view or edit Time Entries before sending them to QuickBooks, click Xora 

Connector > Connect with Xora. 

2. Select the Step 2: Send to QuickBooks tab. 

3. A list of all time entries that were brought in from Xora will appear here.  By default 

All times will appear.  You can use the Filter by View dropdown at the top left to view 

either those Ready to Send, Already Sent or All.  If you do not see any times 

appearing, set a date range for View From and View To and click Refresh. 

4. By default, the fields appearing will be Employee, Customer, Start Time, End Time, 

Duration, Adjustment and Already Sent. 

5. To view or edit a Time Entry, click the Go To link on the left. 

6. Here adjustments can be made to each field and saved.  Any changes will not affect 

Time Entries that have already been sent to QuickBooks. 

7. When you are ready to post the time(s) to QuickBooks, use the checkboxes on the 

left and click Send Selected to QuickBooks TimeTracking, or click Send All to 



QuickBooks.  The time will be sent over only if it has not already been sent, which 

is indicated by the Already Sent column.  If there are any problems with sending any 

of the time entries, none will be posted to QuickBooks. 

8. During the sending process an employee, date, service item and payroll item and 

note will be sent.  The actual duration in minutes that is sent to QuickBooks, will be 

the Duration (min) after Adjustment (min) is subtracted from it. 

9. You can click on the tab Xora Connector > Time Tracking to view which times are 

considered sent to QuickBooks.  Make sure to click the Refresh button to refresh the 

grid. 

 

In order to perform a quick mapping, click on the Customer/Xora Job Number that is 

appearing in the Customer column.  This will bring up the Job/Customer Mapping window 

and will automatically fill in the Xora Job Number for you.  Choose a Customer from the 

dropdown list, enter a Job Description and click Save then Close.  You will notice after the 

grid refreshes, that all Xora Job Numbers have been mapped and changed to the 

corresponding QuickBooks Customer.  A quick mapping will only update the Customer 

name, and not associated items in the Send/Map Xora Jobs window. 

Appendix 

QuickBooks Employee Troubleshooting 

 

If the times do not appear in QuickBooks after sending them through the Xora Connector, it 

is possible that there is an issue with a QuickBooks employee.  This is a known QuickBooks 

issue, but easy to rectify.   

 

1. Click on QuickBooks > Resolve Conflicts tab. 

2. Note the employee whose time is not transferring to QuickBooks. 

3. Open QuickBooks. 

4. Open the Employee Center. 

5. Double click on the employee with the same name. 

6. Select the Payroll Info tab. 

7. Place a check inside the “Use time date to create paychecks” checkbox. 

8. Click OK. 

9. Double click on the same employee again. 

10. Select the Payroll Info tab again. 

11. Remove the check from “Use time date to create paychecks” checkbox. (Or it may 

remain checked if this is how you are using it) 

12. Open the Method Integration Engine from the system tray.  This is a brown and 

yellow „m‟ icon next to your clock on your windows task bar.  If you are unable to 

see it, try expanding the system tray. 

13. Click on Synchronize > Changes Only Synchronization. 

14. Once the process is completed, the times should be sent over. 

 

 

Xora Throttling Errors 

If you find that you are unable to retrieve times from Xora through the Method Connector, 

pay close attention to the error message that appears in the Method Xora Connector 

window.  If the error message appears with the word “Xora Error”, this points to an error 



coming from Xora.  It is possible that the information your account is being throttled for 

attempting to get too much data from Xora or too often.  In this case, you can request Xora 

to remove the throttling from your account, which they may do in certain situations.  

Date Range Super Set Rule 

If consecutive Xora API calls have date ranges that are supersets (or same) of the previous 

call, then an error status will be sent to the client e.g.  

1. From Date: 10:00, To Date: 11:00 Status: OK From Date: 10:00 To Date: 12:00 

Status: OK, From Date: 10:00, To Date: 13:00 Status: NOT OK  

2. From Date: 10:00, To Date: 11:00 Status: OK From Date: 10:00To Date: 11:00 

Status: OK, From Date: 10:00, To Date: 11:00 Status: NOT OK  

3. From Date: 10:00, To Date: 11:00 Status: OK From Date: 11:00To Date: 12:00 

Status: OK, From Date: 12:00To Date: 13:00 Status: OK  

4. From Date: 10:00, To Date: 11:00 Status: OK From Date: 10:05To Date: 11:05 

Status: OK, From Date: 10:10, To Date: 11:10 Status: OK 

Date Range Sum Rule 

The sum of date ranges for a given day should not be more than 48 hours. 

Date Range Limit Rule 

If the time window is higher than or equal to 24 hours, the calls can be made between 

certain times on the server.  e.g.: from date 00:00 and to date 24:00, this call is allowed 

only between 8PM PST and 1AM PST. 

Frequency Rule 

The calls can be made within a certain specified frequency.  Any calls below that frequency 

would potentially not be serviced.  e.g.: get location entries call can be made every 15 

minutes.  A call happening more than once within that time would not be serviced. 

 Job Error Count Rule 

The sum of the jobs having errors should not exceed certain limit.  

Item Limit Rule 

The number of items allowed in the request should not exceed the limit. 

 

 

 

Troubleshooting and Support FAQ 

1. I’m Unable to Login to Method 

If you are unable to login to Method, find the Welcome email you received when you first 

signed up for the Method-Xora Connector.  This email was sent to the email account used 

for the sign up process.  The subject of the email is “Welcome to Method's Xora Connector”.  

Once this is located, perform the following: 



 

1. Bring up the Login screen if it is not open already, here: 

https://www.methodintegration.com/method/Login.aspx    

2. Erase what is currently typed into Company Account, User Name and Password. 

3. Enter the Company Account as it appears in the Welcome email. 

4. Enter the User Name as it appears in the Welcome email. 

5. Enter the Password as it appears in the Welcome email.  This is case sensitive. 

6. Click Login. 

7. If you have forgotten your password, but know your Company Account and User 

Name, click Retrieve Password in the Method Login Screen. 

8. If you are still unable to login, make sure you are using either Internet Explorer 7/8, 

or Firefox. 

9. Another suggestion is to ensure JavaScript is enabled.  For example, this can be 

found in Internet Explorer under Tools > Internet Options and then click Security 

> Custom Level.  Under Scripting, Active scripting should be enabled. 

10. If all else fails, call your Method Consultant toll free at 1-888-925-6238. 

 

 

2. Method screens are not loading properly 

Once logged in to Method, it might be apparent that a screen fails to refresh or does not 

load properly.  If this is the case, you will want to perform the following: 

 

1. Ensure you are using either Internet Explorer 7+ or Firefox. 

2. Right Click in the background and choose Reload Page.  If this option is not 

available, try right-clicking in a different section of the screen. 

3. If the issue persists, Sign out of Method by clicking Sign Out in the top right corner. 

4. Close and reopen the browser. 

5. Re-open the browser and login to Method here: 

https://www.methodintegration.com/method/Login.aspx  

6. Ensure that you have JavaScript enabled in your browser. 

7. Ensure that your screen resolution is at least 1024x768 pixels.  You can find this by 

right-clicking on your Windows desktop, choosing Properties, and clicking on the 

Settings tab. 

 

3. My QuickBooks data does not show up in Method 

If upon initially synchronizing Method and QuickBooks, it might be possible that the 

QuickBooks information does not show up in Method.  Alternatively, you might find that the 

synchronizing was working, but has now stopped.  In either case, you will want to perform 

the following: 

 

1. In Method, click the QuickBooks tab. 

2. Click the Resolve Conflicts sub tab. 

3. Click the Refresh button.  

4. Ensure that there are no outstanding conflicts.  You may choose to either accept or 

reject the change.  A conflict occurs when a record is edited in both QuickBooks and 

Method at once.  

5. Open QuickBooks, and the Method Integration Engine should open as well. 

https://www.methodintegration.com/method/Login.aspx
https://www.methodintegration.com/method/Login.aspx


6. Open the Method Integration Engine (Usually found in the system tray with the 

following icon:  )  If the program is not running, launch it from the Start menu. 

7. Ensure that you are currently connected.  You will need to verify that you have an 

internet connection, and that you have typed in the Company Account, User Name 

and Password exactly as they appear in the Welcome to Method's Xora Connector 

email. 

8. Click Synchronize > Full Synchronization. 

9. If there are any errors in the activity log during synchronization, make sure 

QuickBooks is up to date.  You can check for updates in QuickBooks by clicking Help 

> Update QuickBooks.  If there is still an error in the log, read the error message 

carefully, you might need to stop synchronization with a QuickBooks transaction 

type.  This can be done in Method by clicking the QuickBooks > Synchronize, then 

click Show Options per transaction type (click here).  If you set the 

corresponding table to None, Method will not synchronize this table with QuickBooks. 

10. If there are no errors in the log during synchronization, remove Method from the 

QuickBooks integrated applications screen and resynchronize.  This can be done in 

QuickBooks by clicking Edit > Preferences > Integrated Applications > 

Company Preferences.  Here you will need to delete Method from the list.  Once 

this is done, reopen the Method Integration Engine and click Synchronize > Full 

Synchronization.  You will be prompted with an application certificate, make sure 

to select Yes Always, continue (with admin selected) and done. 

 

4. My employees aren’t being listed in Method 

If you find that employees are missing in Method under the Step1: Get Xora Time screen or 

under the Send to Xora screen, make sure you perform the following in Method: 

 

1. Check the Xora Connector > Employees tab.  If the employee does not appear 

here there is an issue with synchronization between Method and Xora.  In which case 

check for conflicts under QuickBooks > Resolve Conflicts or resynchronize from 

the integration engine by clicking Synchronize > Full Synchronization. 

2. Make sure that the employee is setup as a Xora user.  This can be done by the 

clicking Xora Connector > Employees tab in Method.  Next click the Additional 

Info tab.  The user should be checked as a Xora User, and Xora Employee Number 

should not be blank.  It is very important the Xora Employee Number match what is 

in Xora.  This can be found in the Xora account at https://apps.xora.com under 

Setup > Users > View/Edit Users. 

3. If you are on the Step1: send to QuickBooks tab/ Sent to Xora screen and no 

employees are appearing, and you have verified they are setup properly.  Right click 

in the background and choose Reload Page. 

 

5. Sending Jobs to Xora failed 

When sending a job to Xora, there is a chance that it can fail, and an error message will be 

displayed to at the bottom, beside Xora Schedule Status.  The error message will usually 

explain why the job failed to go over to Xora. In order to send a job from Method into Xora, 

it must meet the following requirements: 

 

https://apps.xora.com/


15. The job you are sending must have a Xora Job Number and a Job Description.  This 

can be verified from the Send/Map Xora Jobs tab. 

16. If you are not sending the job as unassigned, you must select one or more 

employees. 

17. The scheduled Start Time must be between the Available From and Available To 

time. 

18. The Available To Time must be greater than the current time. 

19. The job must not already be scheduled in Xora and uncompleted. This can be 

checked by logging into Xora here: https://apps.xora.com and then by clicking 

Dispatch > View Scheduled Times.  Be aware that the Job might exist 

somewhere in the past, present or future, and for the same or different Xora User. 

 

6. Retrieving Times from Xora failed 

If you find that you are unable to retrieve times from Xora through the Method Connector, 

pay close attention to the error message that appears in the Method Xora Connector 

window.  If the error message appears with the word “Xora Error”, this points to an error 

coming from Xora.  Also, make sure you meet the following criteria: 

 

1. The throttling has been relaxed on the Xora Account. 

2. You must have the Microsoft 3.5 .Net Framework installed.  This can be downloaded 

here: http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-

4E35-B531-508D977D32A6&displaylang=en If the Xora Connector is failing to run, 

make sure you have setup your browser as discussed in the Prerequisites section.  

Additionally, you will want to make sure all of the .Net framework updates have been 

installed. 

 

 Open Internet Explorer and click Tools > Windows Update.   

 Click the Custom button and a search will commence.   

 Once the search completes, click the Software Optional link and download any 

updates pertaining to the .Net framework. 

 

Note: Additional updates can become available after installing new Windows 

Updates.  The previous steps will need to be performed multiple times, until no 

new updates are available. 

3.  

4. The Method account information has been entered in Method, under Xora Setup > 

Preferences. 

5. The Xora account information has been entered in Method, under Xora Setup > 

Preferences. (This should be the admin account) 

6. The Xora user is running a version of Xora that is compatible with the Method-Xora 

Connector. 

7. The Method Employee has been properly matched to a Xora User by the Xora 

Employee Number field. 

8. The specified Date range is valid by Xora‟s specifications. 

9. Ensure that you are looking for Shifts/Jobs/Custom Jobs in Xora Setup > 

Preferences. 

10. Ensure the times exist in Xora.  This can be done by running a Combo Job/Shift 

report when logged in at http://apps.xora.com.  

https://apps.xora.com/
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://apps.xora.com/


11. Ensure the times do not already exist in Method.  This can be done by clicking the 

Step2: Send to QuickBooks tab, and filtering the grid on a date range, or by an 

employee or job number. 

 

 

 

7. Sending Times to QuickBooks from Method failed 

 When sending times from Method to QuickBooks it is possible that this process will fail.  This 

is because if there is a problem with one or more times, the entire batch fails in sending 

over. Make sure of the following for the selected times: 

 

1. They are not marked as Already Sent. 

2. They do not have a number or misspelled Customer name in the Customer 

field/column. 

3. The adjustment for a time entry must not be greater than its duration. 

4. The Employee name, Payroll Item name, Billable Status name, Class name and 

Service Item name must be exactly as they appear in QuickBooks. 

 

8. Where are the times located in QuickBooks? 

 After sending times from Method to QuickBooks, the times will be inserted into the Weekly 

Timesheet.  To view the times in QuickBooks: 

 

1. In QuickBooks, open the Employee Center. 

2. Select an employee who had times recently sent to QuickBooks. 

3. Click Enter Time > Use Weekly Timesheet. 

4. Adjust the timesheet so that you are looking at the proper week, where the times 

should appear. 

5. If the times do not appear here, make sure there are no synchronization issues 

between Method and QuickBooks.  This can be done in Method by clicking 

QuickBooks > Resolve Conflicts.  You can also perform a changes only 

synchronization, by opening the Method Integration Engine and then by clicking 

Synchronize > Changes Only Synchronization. 

 

9. Why are times assigned a number instead of a Customer? 

 When times are brought from Xora into Method, the Xora Job number is initially placed in 

the Customer field.  Method then looks in the Send/Map Xora Jobs screen for the same Job 

Number.  If the same Job number is found, Method will alter the time to display the 

Customer Name instead of the Job Number.  Also, if there are any assigned QuickBooks 

items to this paring, they will be assigned to the time entry as well.  Please keep in mind: 

 

1. This process happens when times are being brought into Method, and not after.  This 

means existing times will not be affected. 

2. The Method Xora Connector includes a QuickMapping feature.  This allows you to 

click on the Job Number as it appears in the Customer Column within the Step 2: 

Send to QuickBooks screen.  You can then map the Job number to a Customer, 

enter a description and click Save.  The window will close and all entries in the grid 



will be updated to the proper Customer Name.  This will not update the associated 

QuickBooks items. 

3. If there is no Job Number appearing in the Customer column, this means that this is 

a Shift time and not a Job time, therefore, no job needs to be associated. 

 

 

10. How do I get a time assigned to the correct QuickBooks 
Service Item? 

 If you have service items setup in QuickBooks, and would like to associate one or more to 

Xora times as they are brought into Method, check the following: 

 

1. In Method, click Xora Setup > Launch Preferences.  Here you can set a default 

Service Item to times as they are brought into Method.  Leaving this blank will result 

in no default Service Item being applied. 

2. In Method, click Send/Map Xora Jobs.  In this screen you are able to create a 

mapping of a Xora Job to a Xora Customer.  You can also specify default QuickBooks 

items such as Service time. When jobs are brought into Method and this mapping is 

found, a default service item will be inserted if it has been set. 

3. In Method, click Xora Setup > Launch Mapping (Under Flex Field Value Mapping).  

If you are tracking actual values of Xora Flex Fields, you can create a pairing here.  

This will consist of the FlexField name and value you are looking for.  You can then 

set a default Service Item for this pairing.  When times are brought in, and a 

FlexField match is found, if a service item is set here it will be applied to the time. 

4. In Method, click Xora Setup > Launch Statuses. If you are using Custom Job 

Times in Xora, you can set default QuickBooks items to Job Statuses.  This includes 

Service Time.  Leaving this blank will result in no default Service Item being set. 
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